Forum Discussion

Philip_Jonsson_'s avatar
Icon for Altostratus rankAltostratus
Feb 21, 2019

Problem with VMware Horizon iApp 1.5.5-1.5.6

Hey everyone!

I tried to deploy VMware Horizon using the latest iApp but when I selected to use AFM's recommended settings, I was hit with the following error:

script did not successfully complete: (can't read "app": no such variable
while executing
"iapp_conf create security firewall policy ${app}_firewall_udp rules replace-all-with \{ acceptPackets \{ action accept log no ip-protocol udp st..."
invoked from within
"subst $substa_out"
invoked from within
"if { [info exists [set substa_in]] } {
set substa_out [subst $$substa_in]
set substa_out [subst $substa_out]
} else {
("uplevel" body line 3)
invoked from within
"uplevel {
append ::substa_debug "\n$substa_in"
if { [info exists [set substa_in]] } {
set substa_out [subst $$substa_in]
(procedure "iapp_substa" line 9)
invoked from within
"iapp_substa ::firewall_arr($::allow_afm,$::do_firewall,$::new_firewall,udp)"
(procedure "create_view_udp_vs" line 7)
invoked from within
"create_view_udp_vs 4172 pcoip"
invoked from within
"subst $apm_virtuals($do_apm,$do_smart)" line:1920)

I tried to downgrade to 1.5.5, same story. It started to work when I used 1.5.4 instead.

Has anyone seen this issue before? Must be some kind of bug in the template.

1 Reply

  • I haven't seen this specific error, but I've definitely seen issues with specific versions of iApps. Report it as a bug to support and they'll get it to the dev that maintains the iApps and get it fixed pretty quickly. I'd imagine not many people are using it with AFM so nobody else has hit it.


    The iApp implementation code is just TCL so the line with the error:


    iapp_conf create security firewall policy ${app}

    is trying to create the AFM policy and failing because it can't name it. I wouldn't bother trying to troubleshoot it though, just get it reported and use the new template when it's released.