Forum Discussion

Andi_102219's avatar
Icon for Nimbostratus rankNimbostratus
Dec 08, 2010

GTM - HTTP check through proxy


I try to configure my GTM (v9.4.5) to monitor certain websites on the internet via my balanced proxy servers (ISA 2006).

So I created a TCP based monitor and configured the send string to something like


First, without a receive string (as this didn't work anyway).

After the monitor is created I assigned it to a specific pool and it started making this GET request through the

proxy (traced the log and GTM interface with tcpdump).

The http request got processed by the proxy and the response delivered back to the GTM. Everything's good so

far but the GTM (cluster of 4 GTMs) marks this pool always to DOWN -> "(state: timeout)"

I also tried it with a HTTP monitor but it's always the same result.

Apart from that I tried to set "\r\n" behind the GET request -> no success

What is my fault?

4 Replies

  • Hi Andi,



    Can you try this send string with a TCP or HTTP monitor and check with tcpdump or the server logs to see what the server status is for the request?



    GET HTTP/1.1\r\n\r\n



  • I made already a trace on the GTM and the proxy. The request is sent to the proxy and data is delivered


    back from the proxy to the GTM (everything successful).


    But the GTM marks the pool always as DOWN. Monitor state is "timeout" according to the gtm log.


    From a network point of view, data delivery and proxy behaviour - everything's looking fine.



    I tried a TCP and a HTTP monitor. Both doesn't work! Also with "\r\n\r\n" at the end



    What's working, apart from that, is a simple TCP check if the proxy port (8080) is alive.


    That's a simple HTTP monitor with a send string "GET /" to the service port.


  • I figured it out by myself. It's working if I make the GET request with GET blablabla HTTP/1.0 instead of HTTP/1.1 :-)
  • Maybe the proxy server doesn't like an HTTP 1.1 request without a host header? If the URI is fully qualified, per RFC2616 you shouldn't need to specify the host header. But anyway, if it's working with 1.0 you should be fine.