Forum Discussion

trungleon_94305's avatar
Icon for Nimbostratus rankNimbostratus
Mar 10, 2012

Fail to restore the scf configuration from TMOS to

Hello everybody and F5 support team,




Our system have two Big-IP F5 LTM 3600. The old one is running under TMOS 9.4.8 build 355.0 and the new one with TMOS 10.2.2 build 763.3.



I had a backup the scf & ucs configuration on the old one by bigpipe utility command. Then, I uploaded the scf configuration & ucs archive to the new one (using WinSCP follow to the path: /var/local/scf, /var/local/ucs).



After that, i used the bigpipe utility command on the new one to load new configuration



1. bp> import backupfilename.scf


2. bp> config install backupfilename.ucs



But the process can't completed and inform the error syntax argument. I have also tried to use tmsh utility command but it had the same error.



Actually, i think that have a change for syntax argument from TMOS 9.x. to TMOS 10.x.



Urgently, i need your support from Dev Control member and F5 support team asap.



P/S: This attach file is the scf configuration of the old one TMOS 9.4.8 build 355.0. Please help me to edit it.



Thanks so much.


6 Replies

  • did you change hostname (to match the old one) before restoring ucs?


    can you post error message when restoring ucs?
  • Hi Nitass,



    Thank you for your comments. I haven't changed the host name, mgmt ip of the new one (to match the old one) before beforce restoring scf&ucs. Maybe that's why lead to error?



    When i excute the process of restore configuration. After the system backup running config, it load the new config in scf&ucs but error with message "error to excute, not correct syntax argument". Have you ever seen the same error when restore the configuration from TMOS 9.4 to TMOS 10.2.2 (different TMOS architecture).



    I will capture the message error log in the details asap. Please help me to solve that.



    Best Regards.


  • i do not think scf is suitable in your case since v9 and v10 syntax is different. anyway, ucs should work.



    when restoring ucs, you have to change hostname of the new unit to match the old one only. mgmt ip is not needed.



    additionally, you should backup /config/bigip.license file before restoring because it will be overwritten with bigip.license file inside ucs. after restoring, you will get an error about licensing. what you have to do is to replace the correct bigip.license and run "bigstart restart".



    if there is any error message, please feel free to post here.



    this is summary step.


    1. backup /config/bigip.license file


    2. change hostname to match the old one


    3. restore ucs


    4. replace the correct bigip.license file


    5. run bigstart restart



  • Hi Nitass,



    It's great, i will try to test again with ucs archive and follow to your step above. Let you know as soon as finish that.



    Thanks for your suppoting.
  • Hi Nitass,



    I have succeeded with ucs archive when restoring on the new unit. In fact, the host name have to match with the old unit.



    Thank you so much.