Forum Discussion

f5beginner's avatar
Icon for Cirrostratus rankCirrostratus
Mar 06, 2020

Disk partition appdata almost full


could someone help me how to extend appdata or remove some files from it ?


Error message: Disk partition /appdata has only 4% free


I found few commands, to show you how it looks like:

I do not have any experience with managing storage, so please be so kind and explain how to extend filesystem or remove files as for dumies.


Maybe I found solution to remove HD1.1, what do you think about ?




Filesystem               Size Used Avail Use% Mounted on

/dev/mapper/vg--db--vda-set.2.root   419M 225M 168M 58% /

devtmpfs                7.9G 4.0K 7.9G  1% /dev

tmpfs                 7.9G 531M 7.4G  7% /dev/shm

tmpfs                 7.9G 2.2M 7.9G  1% /run

tmpfs                 7.9G   0 7.9G  0% /sys/fs/cgroup

/dev/mapper/vg--db--vda-set.2._usr   5.0G 4.0G 788M 84% /usr

/dev/mapper/vg--db--vda-dat.share    15G 3.0G  11G 22% /shared

none                  7.9G  36M 7.9G  1% /shared/rrd.1.2

/dev/mapper/vg--db--vda-set.2._config 2.1G 304M 1.7G 16% /config

/dev/mapper/vg--db--vda-set.2._var   2.9G 1.3G 1.6G 45% /var

prompt                 4.0M  28K 4.0M  1% /var/prompt

none                  7.9G  52M 7.8G  1% /var/tmstat

/dev/mapper/vg--db--vda-dat.log    2.9G 399M 2.3G 15% /var/log

/dev/mapper/vg--db--vda-dat.appdata   30G  27G 1.3G 96% /appdata

none                  7.9G   0 7.9G  0% /var/loipc

/dev/loop0               298M 298M   0 100% /var/apm/mount/apmclients-7180.2019.119.331-4683.0.iso

none                  7.9G   0 7.9G  0% /mnt/sshplugin_tempfs



[root@f5lb02:Active:In Sync] config # find /appdata -xdev -type f -exec du {} \; | sort -rn | head -20

2556204 /appdata/mprov/local/HD1.2/mysqldb/AVR/AVR_STAT_ENFORCED_ACL_T#P#LAST.MYI

2188768 /appdata/mprov/local/HD1.2/mysqldb/AVR/AVR_STAT_ENFORCED_ACL_T#P#LAST.MYD

1591000 /appdata/mprov/local/HD1.2/mysqldb/AVR/AVR_STAT_STAGING_ACL_T#P#LAST.MYD

1364460 /appdata/mprov/local/HD1.2/mysqldb/AVR/AVR_STAT_STAGING_ACL_T#P#LAST.MYI

1142316 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_CLIENT_IP_T#P#LAST.MYD

999248 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_USER_AGENT_T#P#LAST.MYD

900612 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_CLIENT_IP_T#P#T_2019_0822_140001_1566475201.MYD

867256 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_URL_T#P#LAST.MYD

816976 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_ENFORCED_ACL_T#P#LAST.MYI

778620 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_ENFORCED_ACL_T#P#T_2019_0822_140001_1566475201.MYI

701672 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_RESPONSE_CODE_T#P#LAST.MYD

690524 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_ENFORCED_ACL_T#P#LAST.MYD

658020 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_ENFORCED_ACL_T#P#T_2019_0822_140001_1566475201.MYD

533312 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_RESPONSE_CODE_T#P#T_2019_0822_140001_1566475201.MYD

498264 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_STAGING_ACL_T#P#LAST.MYD

474696 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_STAGING_ACL_T#P#T_2019_0822_140001_1566475201.MYD

439284 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_CLIENT_IP_T#P#LAST.MYI

435888 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_STAGING_ACL_T#P#LAST.MYI

415336 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_STAGING_ACL_T#P#T_2019_0822_140001_1566475201.MYI

354684 /appdata/mprov/local/HD1.1/mysqldb/AVR/AVR_STAT_DOS_VIS_COMMON_ALL_T#P#LAST.MYI



Thank you



7 Replies

  • Hi Lidev, thanks for answer, after I tried to add some free space, I cannot check free space anymore:




    Directory Name         Current Size  New Size

    --------------         ------------  --------

    /config             2273280     -

    /shared             15728640    -

    /var              3145728     -

    /var/log            3072000     -

    /appdata            31457280    -





    [root@f5lb02:Active:Changes Pending] config # tmsh modify sys disk directory /appdata new-size 50457280


    [root@f5lb02:Active:Changes Pending] config # tmsh show sys disk directory

    error: F5::VE::VE_get_dir_sizes -- mdconf_open failed

    directory - internal execution error(Operation not permitted).


    Thank you





    • Lidev's avatar
      Icon for MVP rankMVP

      Have you tried to reboot you F5 BIG-IP and relauch the tmsh command ?

  • Nope, because I´m not sure if it is not issue, because in first article, which you send me is written, that I should see new value of directory, so should I reboot F5 ?

    • Lidev's avatar
      Icon for MVP rankMVP

      in K14952, it's specified that it is necessary to make a save sys config and after a reboot of the F5 device.

  • Hi Lidev,


    it was some error, because after reboot there was the same volume, so I did changes again, and then it works, but I have another problem after reboot, here it is:


    logmysqld[22914] Fatal error db.cpp:exec_query:150 SELECT COUNT(*) from log_data_current errno[23] strerror[Out of resources when opening file './logdb/log_data_current.MYD' (Errcode: 24)


    Should I open an new question ?


    Thank you

    • Lidev's avatar
      Icon for MVP rankMVP

      yes, open a new question on Devcentral and marked this one as solved.