Forum Discussion

MarkM_63051's avatar
Icon for Nimbostratus rankNimbostratus
Feb 14, 2012

Connection Refused



Now that I have my code working, it is time to pin down a connection refused/timeout problem I run into. As long as I have recently logged into the LTM management GUI, my iContol API calls connect flawlessly. If however X amount of time has passed, then my API calls are refused until I once again log into the LTM management GUI. Does anyone have an idea what is going on behind the scenes? One more bit of information, I am using the admin user and password for my API call connections. Should I be using some other user?






6 Replies

  • Mark, I have never heard of this issue before and honestly I'm not how the two would be related. iControl does go over the same management channel as the GUI, but the two are different clients altogether. I don't know how an iControl connection could be sharing connection state with a web based GUI request. Each use a independent connection and each send their own set of credentials across the wire. What version of LTM are you on and what client toolkit are you using for iControl. Also, what error are you receiving? Is it a connection refusal or an authentication error. I'm stumped on this one...





  • Hi Joe,



    Thank you for looking into my problem. I am getting " Connection refused: connect". I am using LTM 11.1 and iControl 11.1.0.



    2 thiings:



    1. I do not run into this problem when I run my JUnit test cases against the F5 from within Eclipse.


    2. I do run into this problem when I test my code through HP's Operations Orchestration Workflow environment. It is as if a timeout





  • I have created 3 new adimin users:



    1. Identicle to admin.


    2. Like admin but console set = Advanced shell instead of disabled


    3. Like admin but console set = tmsh instead of disabled.



    I will check tomorrow morning after the "timeout" value has expired to see if any of these new users have the same problem.



  • I tested my code this morning but did not see the problem. I will have to wait for it to happen again.




  • I don't think anything native to the F5 or iControl would be causing this. Maybe there's a session-aware firewall or some other security feature on the network that's involved.