Hi Jim,
That helps a bit.
I'm also having some issues getting my gateways set properly.
Our network engineers set up the ports on our 6509 so far as single trunked interfaces carrying 3 vlans - 32/112/114. vlan 32 is client/server, and vlan 112/114 is for storage(netapps). 112 I'm not actually using on the ARX yet. The 6509 ports will be set up in a lacp channel soon.
On the ARX side, I set up my ports in a lacp channel. Config is below. I'm not doing something right. The behavior I'm seeing is:
I can't add a default gateway for vlan 32. Running ip route 0.0.0.0 0.0.0.0 10.17.32.1 doesn't do anything (show ip route does not change). I assume this is because my proxyIP's are on vlan 114.
I can add a default gateway for vlan 114. Running show ip route and show ip route monitor show it added, but then pinging to another IP on that same network fails, and then the route is removed. I don't know if part of my problem is my channel config at the bottom with the cisco side not being channeled yet.
Any thoughts as to where my breakdown might be? 114 is a routable network.
SUMC01ARX01(cfg) ip route 0.0.0.0 0.0.0.0 10.17.114.1
SUMC01ARX01(cfg) show ip route
Destination/Mask Gateway Cost Interface Age
---------------------------------------------------------------------
0.0.0.0/0 10.16.30.1 128 Mgmt 822250
0.0.0.0/0 10.17.114.1 128 VLAN114 2
10.16.30.0/24 0.0.0.0 0 Mgmt Direct
10.17.32.0/22 0.0.0.0 0 VLAN32 Direct
10.17.32.0/22 0.0.0.0 128 VLAN Direct
10.17.114.0/23 0.0.0.0 0 VLAN114 Direct
10.17.114.0/23 0.0.0.0 128 VLAN Direct
SUMC01ARX01(cfg) show ip route monitor
Destination/Mask Type Gateway Cost Status Details
------------------------------------------------------------------------------
0.0.0.0/0 Mgmt 10.16.30.1 128 Up Current Gateway
0.0.0.0/0 VLAN 10.17.114.1 128 Up Current Gateway
10.17.32.1 128 Down Unreachable
SUMC01ARX01(cfg) ping 10.17.114.23
PING 10.17.114.23 (10.17.114.23) 0 data bytes
Ping timeout 10.17.114.23 from 1.5
Ping timeout 10.17.114.23 from 1.5
Ping timeout 10.17.114.23 from 1.5
Ping timeout 10.17.114.23 from 1.5
-------10.17.114.23 ping statistics
4 packets transmitted, 0 packets received, 100% packet loss
round-trip min/avg/max 0/0/0 ms
SUMC01ARX01(cfg) show ip route monitor
Destination/Mask Type Gateway Cost Status Details
------------------------------------------------------------------------------
0.0.0.0/0 Mgmt 10.16.30.1 128 Up Current Gateway
0.0.0.0/0 VLAN 10.17.114.1 128 Down No Reply
10.17.32.1 128 Down Unreachable
SUMC01ARX01(cfg) show ip route
Destination/Mask Gateway Cost Interface Age
---------------------------------------------------------------------
0.0.0.0/0 10.16.30.1 128 Mgmt 822305
10.16.30.0/24 0.0.0.0 0 Mgmt Direct
10.17.32.0/22 0.0.0.0 0 VLAN32 Direct
10.17.32.0/22 0.0.0.0 128 VLAN Direct
10.17.114.0/23 0.0.0.0 0 VLAN114 Direct
10.17.114.0/23 0.0.0.0 128 VLAN Direct
=======configuration=======
hostname SUMC01ARX01
vlan 32
description "Vlan 32 - Client"
exit
vlan 114
description "Vlan 114 - Storage"
exit
ip proxy-address 10.17.114.161 255.255.254.0 vlan 114
ip proxy-address 10.17.114.162 255.255.254.0 vlan 114
ip proxy-address 10.17.114.163 255.255.254.0 vlan 114
ip proxy-address 10.17.114.164 255.255.254.0 vlan 114
show ip proxy-address
config
vlan 114
tag 1/1 to 1/10
exit
vlan 32
tag 1/1 to 1/10
exit
interface gigabit 1/1
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
interface gigabit 1/2
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
interface gigabit 1/3
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
interface gigabit 1/4
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
interface gigabit 1/5
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
interface gigabit 1/6
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
interface gigabit 1/7
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
interface gigabit 1/8
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
interface gigabit 1/9
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
interface gigabit 1/10
description "Primary Client/Server Link"
speed 1000-full
no shut
exit
int gig 1/11
redundancy protocol
no shutdown
exit
int gig 1/12
redundancy protocol
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 10.17.32.1
int vlan 32
description "In band management IP - 10.17.32.165"
ip address 10.17.32.165 255.255.252.0
no shut
exit
int vlan 114
description "In band management IP - 10.17.114.165"
ip address 10.17.114.165 255.255.254.0
no shut
exit
; vlan 32 and 114
channel 1
redundancy protocol 1/1 to 1/8
vlan-tag 32
vlan-tag 114
lacp passive
description "1-8 lacp"
no trap shutdown
exit