cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Server specification in XML exported ASM Policy

JCaine
Altocumulus
Altocumulus

Hello folks,

 

I would like to import an ASM policy I have exported (under XML format) from a F5 node, let's say, F5_A to another F5 node, F5_B. This policiy was associated to a virtual server named as, let's say VS_1 (on F5_A) and I would like to associate it to VS_2 (on F5_B). But the problem is that when I import the ASM policy on F5_B, I am not proposed to choose a VS which to assign it to. Thus, the imported policy has no VS assigned. After having a look into the XML file, I notice that there is no tag to specify the VS.

Do you know this tag or any clue with this?

Thanks.

 

Regards

7 REPLIES 7

Erik_Novak
F5 Employee
F5 Employee
  1. Go to your Virtual Server List and click the name of the virtual server (F5_B),
  2. From the Security tab, select Policies.
  3. Enable Application Security Policy and then see if the policy you imported is listed in the policy menu.

Does that work?

JCaine
Altocumulus
Altocumulus

  Thanks for your reply.

Unfortunately with my current profile, I connot access the VSs list. What I would relaly like to do is specify the target Virtual Server (VS_2) in the XML export of the orignal policy; something like

<virtualserver>VS_2</virtualserver>

 

Erik_Novak
F5 Employee
F5 Employee

It is possible to edit the XML file the way you are working. However, I think the larger issue is that ASM is not enabled on VS_2 so you won't be able to import any security objects. Can you ask the LTM admin to verify if Application Security Policy is enabled on the VS that you need? That should help immensely.

JCaine
Altocumulus
Altocumulus

Hello  

Jus checked : ASM is enabled on VS_2.

But still did not find the appropriate XML tag for the VS specification in XML policy.

I'm affraid : I didn't get you. Could explain more?

Erik_Novak
F5 Employee
F5 Employee

Can you try adding the policy to VS_2 from the Security tab?

Yes, I can link my new policy from the security tab and link it to VS_2 (by clicking on create but still not from importing my XML).