cancel
Showing results for 
Search instead for 
Did you mean: 

no space left on device

sukru_isik_8872
Nimbostratus
Nimbostratus

I have a f5 3900 and I have a disk problem.when I want to take a ucs file,I see an error like that:

 

"can't write temp config file "bigip.conf",in temp dir "/.config.tmp/xI06TM",No space left on device "

 

Filesystem Size Used Avail Use% Mounted on

 

 

/dev/mapper/vg--db--sda-set.1.root

 

287M 287M 0 100% /

 

/dev/mapper/vg--db--sda-set.1._config

 

3.0G 86M 2.8G 3% /config

 

/dev/mapper/vg--db--sda-set.1._usr2.0G 1.5G 401M 80% /usr

 

/dev/mapper/vg--db--sda-set.1._var

 

3.0G 352M 2.5G 13% /var

 

/dev/mapper/vg--db--sda-dat.share.1

 

30G 196M 28G 1% /shared

 

/dev/mapper/vg--db--sda-dat.log.1

 

6.9G 367M 6.2G 6% /var/log

 

none 4.0G 708K 4.0G 1% /dev/shm

 

none 4.0G 16M 3.9G 1% /var/tmstat

 

none 4.0G 1.3M 4.0G 1% /var/run

 

prompt 4.0M 28K 4.0M 1% /var/prompt

 

/dev/mapper/vg--db--sda-app.ASWADB.set.1.mysqldb12G 2.9G 8.4G 26% /var/lib/mysql

 

none 4.0G 8.0K 4.0G 1% /var/logd

 

/dev/mapper/vg--db--sda-app.avr.dat.avrdata

 

3.8G 65M 3.5G 2% /shared/avr

 

 

 

what can I do about that?is there anyone experinces this issue?

 

5 REPLIES 5

nitass
F5 Employee
F5 Employee
/dev/mapper/vg--db--sda-set.1.root

 

287M 287M 0 100% /what eats up space on root (/)?

shaggy
Nimbostratus
Nimbostratus

SOL14403: Maintaining disk space on the BIG-IP system (11.x) http://support.f5.com/kb/en-us/solutions/public/14000/400/sol14403.html

 

SOL12263: Maintaining disk space on the BIG-IP system (9.x - 10.x) http://support.f5.com/kb/en-us/solutions/public/12000/200/sol12263.html

 

I have run into issues in the past with admins using their /home/ folders, which are in the root partitions, for file storage instead of in the /shared/ partition.

 

Sil
Nimbostratus
Nimbostratus

I run into the same question: what eats up space on root?

 

Why there are only 427M total space for / ex works? Actually we have 58M free space, only 14%. Is this critical? What to do? We dont stored any datas on the f5, no tcpdumps, no stuff in home directories and so on.

 

Is 58M free space enough for the f5 to work in a stable and performant way? Or do we have to adjust the partition structure?

 

I hope someone can help 🙂

 

Update: we solved it, it was our fault - we monitor our f5's with ansible and did not set the parameter keep_remote_files=false

 

Gregory_Thiell
F5 Employee
F5 Employee

It could be related to this issue:

 

K65094414: Temporary directories and files created for tmsh commands may not be deleted

 

You should be able to safely delete the temporary files as indicated in the article.

 

mamillapalli
F5 Employee
F5 Employee

Hi,

When I have faced such issue, I have removed unwanted files with .gz and .tar extensions in /var folder.

Also I have removed all files in /tmp folder.

Usually BIGIP images also occupies more space. It is recommened to remove unwanted bigip image files.

 

Thanks,

Rohitha