cancel
Showing results for 
Search instead for 
Did you mean: 

Exchange 2016 iApp LTM on newer versions (v14.1 and above)

MarkusNeubauer
Nimbostratus
Nimbostratus

Hi all,

 

I recently upgraded a existing F5 LTM cluster running 12.1.5.x towards version 15.1.x

On the cluster there where several Exchange 2016 iApps (f5.microsoft_exchange_2016.v1.0.2) with all pool monitoring features enabled (IMAPS inbox check).

 

After the upgrade the IMAPS inbox health check with the external monitor "imap_adv_eav" failed.

There were several logs regarding authentication errors.

 

After investigation we saw a different behaviour of cURL which is executed withn the external monitor script.

This is due to a new version of cURL (7.47.1 instead of 7.25 on 12.1.5). This newer version is in place in all images from 14.1.x till 16.0.x (this is what i tested).

 

SOLUTION:

If you want the external monitor to work again, you need to skip the newly added GSSAPI (Kerberos v5) which is build into the newer cURL version.

This can be archived by adding the parameter --login-options "AUTH=NTLM" to the curl command in the external script. This will force the system to use NTLM auth like in previous versions and therefor will work as expected again.

 

Greets

Markus

0 REPLIES 0