cancel
Showing results for 
Search instead for 
Did you mean: 
Login & Join the DevCentral Connects Group to watch the Recorded LiveStream (May 12) on Basic iControl Security - show notes included.

Big IQ High Availability Configuration Fails

Jeff_Nadolna
Nimbostratus
Nimbostratus

I have two Big IQ Virtual Machines built from the Big IQ 7.1.0.1-133 software. There are no firewalls between the two, but they do reside on two separate VM hosts. When I configure the High Availability with no auto failover (no DCDs deployed yet), the process hangs at "Configuring Database Replication" for a long time but it will eventually say the process is complete. At that point, the VM that should be the primary says it is still in Standalone mode and the VM that is secondary has the configuration replicated but the web GUI doesn't come up. The reason I know the configuration is replicated, is because when I reboot the hosts and check the High Availability settings, the primary says it is in a failed High Availability state and the secondary is in a successful state. there is also an error on the primary stating "Secondary is not actively streaming. Postgres may be down.". I checked the logs for Postgres and Tokumonx and I'm seeing fatal errors. Specifically, that the role "root" doesn't exist.

 

My question: where else should I be looking to troubleshoot this issue? Has anyone run into this issue and just know the answer?

 

Thank you

1 REPLY 1

Lidev
MVP
MVP

Hi Jeff,

Have you tried the different stuff proposed in this link : Troubleshooting BIG-IQ High Availability Auto Failover Issues ?

 

Regards