cancel
Showing results for 
Search instead for 
Did you mean: 

APM Customization Logo

kgaigl
Cirrostratus
Cirrostratus

Hello,

 

I want to customize a logon page for APM with our own Logo, it's diplayed fine in the preview but not on the real Logon Page.

I've read this Article:

https://support.f5.com/csp/article/K42811815

 

and I checked the File Permissions, I only see the placeholder for the png.

 

When I inspect the Element in the Browser I get the path:

<img src="/public/images/customization/Common/AP-NVSBT1AP_general_ui/logo_image_de.png">

 

but the path on the F5 is:

public/images/customization/Common/logo_login_bg.png

 

any help, where to look, to solve this Problem?

 

thanks

5 REPLIES 5

Hi  ,

 

are you using Standard or Modern Customization and which BIG-IP version are you on?

I could successfully change the Header Logo in Access ›› Profiles / Policies : Customization : Quick Start/Basic.

In my test I was using 15.1.3 and I tried with Standard as well as Modern Customization.

The naming convention in K42811815 did not make a difference in my tests, I uploaded files named logo_xyz.png but also test_xyz.png.

I assume you clicked on Apply Access Policy?

 

On the filesystem the files are available in /var/sam/www/webtop/public/images/customization/Common/

[root@bigip01:Active:Standalone] Common # cd /var/sam/www/webtop/public/images/customization/Common/ [root@bigip01:Active:Standalone] Common # ll total 16 drwxr-xr-x. 2 tomcat webservices 4096 Oct 14 17:53 access_demo01_general_ui drwxr-xr-x. 2 tomcat webservices 4096 Oct 14 18:07 access_demo02_general_ui -r--r--r--. 1 tomcat webservices 3803 Oct 14 18:07 logo_my_example2.png -r--r--r--. 1 tomcat webservices 2448 Oct 14 17:52 logo_my_example.png

Once you go into one of the subfolders (e.g. access_demo01_general_ui) you will see that they contain a symlink to the logo in this folder.

[root@bigip01:Active:Standalone] Common # cd access_demo01_general_ui/ [root@bigip01:Active:Standalone] access_demo01_general_ui # ls -hla total 12K drwxr-xr-x. 2 tomcat webservices 4.0K Oct 14 17:53 . drwxr-xr-x. 4 tomcat webservices 4.0K Oct 14 18:14 .. lrwxrwxrwx. 1 root root 74 Oct 14 17:53 logo_image_en.png -> /var/sam/www/webtop/public/images/customization/Common/logo_my_example.png

Hope this helps.

 

KR

Daniel

kgaigl
Cirrostratus
Cirrostratus

Hi Daniel,

 

I'm on v 14.1.4.4

I realized the Symlink later, yes, I tried it with Quick Start/ Basic as well as with General and the Preview is just fine,

the files are correct:

 

[root@ldb-ara27-rz-01:Active:Standalone] AP-NVSBT1AP_general_ui # ls -hla total 28K drwxr-xr-x. 2 tomcat webservices 4.0K Oct 12 12:10 . drwxr-xr-x. 6 tomcat webservices 4.0K Oct 12 13:00 .. lrwxrwxrwx. 1 root root 72 Oct 12 08:20 logo_image_de.png -> /var/sam/www/webtop/public/images/customization/Common/logo_login_bg.png lrwxrwxrwx. 1 root root 72 Oct 7 14:42 logo_image_en.png -> /var/sam/www/webtop/public/images/customization/Common/logo_login_bg.png lrwxrwxrwx. 1 root root 72 Oct 12 12:10 logo_image_mobile_de.png -> /var/sam/www/webtop/public/images/customization/Common/logo_login_bg.png lrwxrwxrwx. 1 root root 72 Oct 12 08:18 page_image_default_de.png -> /var/sam/www/webtop/public/images/customization/Common/logo_login_bg.png lrwxrwxrwx. 1 root root 72 Oct 11 08:02 page_image_default_en.png -> /var/sam/www/webtop/public/images/customization/Common/logo_login_bg.png [iv0152@ldb-ara27-rz-01:Active:Standalone] AP-NVSBT1AP_general_ui #

I want to use the file logo_logon_bg.png

Looks all OK. Maybe hitting this bug?

https://cdn.f5.com/product/bugtracker/ID759392.html

Hi Daniel,

 

sorry, had some other other issues, now I'm back on the Problem.

I read about the Bug ID but I don't understand the workaround...

kgaigl
Cirrostratus
Cirrostratus

If I want to paste the URL of the Logo (SymLink) in a Browser-Window I get "ERR_CONNECTION_RESET"