Forum Discussion

F53's avatar
Icon for Nimbostratus rankNimbostratus
May 25, 2020

WebUI shows error: Error getting auth token from login provider Version

I trying to say that also I have an error issue with version 13.1.1, I can't display the network mapping when I created Virtual servers, and also when I'm checking High availability overview I'm getting error as well.


Did you face this error message "Error getting auth token from login provider"


when I tried to research this error I got "Bug ID 717174: WebUI shows error: Error getting auth token from login provider" i found from F5 devcentral document to connect to ssh console and type this command :


bigstart restart restjavad

bigstart restart restnoded


Still i getting this error even after I typed these commands

4 Replies

  • We had this same error last week. I don't think your issue is related as you've sighted two versions. With that in mind, check out the following of which the second may be related.


    Our issue was that restjavad was constantly restarting and tamd was down. This was because the VE was unfortunately Rest on the VMWare side causing the file system to be mounted readonly. When our automated inventory job kicked off it would throw these errors in the GUI.


    I would run the following:

    tmsh show /sys service restjavad

    tmsh show /sys service tamd


    If either is down, then restart. Also the following article helped with the file system issue:



  • F53's avatar
    Icon for Nimbostratus rankNimbostratus

    Hello Jeff,


    Thanks for having this issue answering by you.


    I did the what you mentioned the reply and nothing was solved still the having the issue

  • Hi,


    You'll need to troubleshoot further by checking the relevant log files.

    # cat /var/log/restjavad.0.log | more

    # cat /var/log/restnoded/restnoded.log | more


    Post the information into this Question if you require further assistance understanding if the output is relevant to the issue. If you don't see any noticeable issues then could be cosmetic. Try restarting the httpd process:

    # tmsh restart sys service httpd (not service impacting)


    The bug article also suggests restarting the restjavad / restnoded processes will 'usually' fix this issue, however, as it's not your VE may have memory issues. You can start by viewing how much memory is first available and progress from there using Linux utilities such as Top or vmstat.

    # tmsh show sys memory

    OR # free -m


    Kind regards


  • F53's avatar
    Icon for Nimbostratus rankNimbostratus

    Hello Ben,


    hope you staying safe.


    Actually i upgrade the version to and the issue i had was resolved, now i can see my network map and pool and node associate with it.