Forum Discussion

LillyM_9417's avatar
Icon for Altostratus rankAltostratus
Oct 05, 2011

VE- F5 version 11




I tried to "Reload an External Class Files" in v11 also VE-F5.


I read in my documents it says, in version11 , to reload an external class files Instead of "b load" command, the following to commands should be used. But I got the these error.


Any answer will be appreciated.



(tmos) modify cli admin-partitions update-partition Common


Syntax Error: admin-partitions may only be specified in a config file



(tmos) modify ltm data-group MYDATAGROUP access-mode read-only


Syntax Error: "MYDATAGROUP " unexpected argument

8 Replies

  • i understand u get the command from:


    Bigpipe Mappings




    anyway, i don't see that command as well. i am running 11.0.0 on 3600 platform.



    this is command i found. b is external data group name and a is data group file name.


    root@bigip1(Active)(/Common)(tmos) modify ltm data-group external b external-file-name a


  • Thanks a lot for your response, Here is the command output. I also cannot create a datagroup. I asked this question too.



    root@(Active)(/Common)(tmos) modify ltm data-group external a external-file-name /var/class/a.txt


    01020036:3: The requested class (/Common/a) was not found.










    I am trying to create a new data group in VE-F5 version 11. I got the following error


    "0107134a:3: File object by name (NOT_VALID_SELECTION) is missing."


    What can be the reason of this?


    In previous version, I can give the path name of the external files and creating new data groups but now, I cannot write any thing in File Name field. It only says select... ????????





  • i imported data group file via gui since i did not see an option to specify local file via tmsh.



    the data group file is in system, file management, data group file list menu.



    ) list sys file data-group


    sys file data-group test {


    checksum SHA1:59:140c98ed7d3dbfbdb49e74d2967ba029dc86d363


    create-time 2011-10-05:07:53:23


    created-by admin


    last-update-time 2011-10-05:07:53:23


    mode 33188


    revision 1


    size 59


    type string


    updated-by admin





    then i created external data group via tmsh.



    ) create ltm data-group external test_datgroup external-file-name test



    ) list ltm data-group


    ltm data-group external test_datgroup {


    external-file-name test


    type string




  • When I tried to import my old external data group files to new virtual F5, I got this error:



    01070627:3: The string data group external file (/config/filestore/.stage_d/13_d/Common_d/data_group_d/:Common:dsb1garc_1) has an invalid format, line: 2.



    I download the external files from other F5 through sftp type ascii (cause file includes strings), but now I cannot import them?



    If you dont mind can you send your external files few lines?





    Thanks a lot.
  • initially, i tried this but unfortunately it did not work - got the same error as yours.



    "str1" := "value 1",


    "str2" := "value 2",



    i think it might cause by text editor, so i changed it to this and it worked.



    "str1" := "value 1", "str2" := "value 2",



    after that, i went to gui and reverted it back (in gui) and it still worked.



    "str1" := "value 1",


    "str2" := "value 2",



    just for reference



    iRules Data Group Formatting Rules by Jason


    Hello Nitas,



    I changed like this manually and it worked. Is there any way (You say: i think it might cause by text editor, so i changed it to this and it worked.) to make it work automatically? Which text editor do I need to use ?



    Thanks a lot.



    in version 10.x.x







    in version 11


  • Is there any way (You say: i think it might cause by text editor, so i changed it to this and it worked.) to make it work automatically? Which text editor do I need to use ?would u mind opening a support ticket and seeing what they say?
  • Now that the formatting of the classes themselves are complete, I’d like to point out one more issue, and that’s file formatting. If you’re editing all the external classes by hand on the BIG-IP, you have nothing to worry about. However, if you edit them on an external system and copy them over, be careful on which editor you choose. The Unix/Linux line terminator is a line feed (0x0A) whereas Windows default is a carriage return/line feed (0x0D0A) and Mac typically employs just a carriage return (0x0D). The file needs to be formatted in unix-style. I use gVim on my windows laptop. By default, it uses the dos-style, as evidenced in my hex readout in gVim below:i think it's. i just noticed there is an option in textpad to save file in pc (default), unix or mac format. when using pc format, winhex shows line terminator is CRLF as Jason mentioned.