Forum Discussion

Gihad_296649's avatar
Icon for Nimbostratus rankNimbostratus
Feb 02, 2017

Session Variable names with special characters



I am trying to access a session variable in the Policy Editor and display it in a message box but that variable name has special characters and it keeps showing the variable name instead of the value


I am using the following which displays normally: session.user.sessionid = %{session.user.sessionid} session.saml.last.identity = %{session.saml.last.identity}


The one that has a problem is: dataofbirth = %{}


I tried to escape the dots in using \ but it doesn't work


I also tried to escape the slashes and the colon and it doesn't work http:\/\/\/ws\/2005\/05\/identity\/claims\/dateofbirth


Any ideas?


Or maybe guidance on how to access saml session variables that hold the attributes values in general would be appreciated.


Thanks a lot.


1 Reply

  • Hi Gihad,


    I have the same issue in 14.1.2 version. Do you know how to write the session variable?


    The variable %{} doesn't work.


    I've printed the variable with a logging box and it's empty. However, the variable %{session.saml.last.identity} works.


    Thanks, best regards.