Forum Discussion

James_78615's avatar
Icon for Nimbostratus rankNimbostratus
May 19, 2009

GTM serves private IP, not the public translation address




I am trying to configure my GTMs to serve DNS responses with the public IP address of a local virtual server.






GTM ----------------|







The GTM monitors the local LTM virtual server but the HOST needs to receive the public IP when receiving a DNS request from the GTM.



On the GTM, I have manually configured a translation IP address under the virtual server When I do a DNS request to my wideip, I only receive the private IP, not the translated IP



When I reverse the IPs in the virtual server, the GTM tries to poll which it cannot get to and fails.



Any ideas how to get the GTM to serve the translation address?






2 Replies

  • Hi James,

    I never tweaked those settings you mentioned but here is an iRule that may work if applied to the WIDEIP

     when DNS_REQUEST { 
     if { [DNS::rrname] eq "" } { 

  • I noticed this behavior in early GTM version (pre-9.2.5) but if setup correctly should bear the correct IP address. The address should be your public IP, the translation should be your real IP. I'd open a case with support if this isn't working.