Forum Discussion

Daniel_55334's avatar
Icon for Altostratus rankAltostratus
Nov 16, 2011

curl output not found in tcpdump

I tried to use curl to test a monitoring script and found the desired pattern to match. However the monitor still marks the pool member as down. I then used tcpdump to check the actual packet but I did not find that pattern.

Am I missing something?


8 Replies

  • what the tcpdump command did you use? was the vlan name correct?
  • I used "tcpdump -i external -X -s0 host xxx and port 80". vlan name is correct as I really see related output, but just not the desired pattern.

    What I see is that there are a lot of output when using curl, but just very little during tcpdump capture when the monitor was turned on.


  • pool member is in external vlan, isn't it?



    have you tried to capture packet to file instead of screen and have a look it using tool such as wireshark?




    tcpdump -i external:nnn -s0 -w /var/tmp/output_file.pcap host x.x.x.x and port 80
  • Yes I did check the capture in wireshark but still did not find the expected text pattern. What may be the cause of this?
  • how did you create monitor script file? did you upload it from pc to f5?



    if yes, would you mind trying copy-and-paste instead? i have come across an issue about selinux similar to sol below.



    sol11455: Moving a file across the BIG-IP file system may cause SELinux to deny access to the file

  • no I just input it in the WEBUIisn't it external monitor script?



    may i have a look your configuration? just wondering if i can try in my unit.
  • Hamish's avatar
    Icon for Cirrocumulus rankCirrocumulus



    Is the poolmember expecting extra headers perhaps? The default HTTP monitors don't include the extra headers. And are probably HTTP/0.9 as well, which a lot of servers just don't like.



    Make sure your monitor includes all the headers that your curl uses... (curl -v will show them to you).