Forum Discussion

JamesCrk's avatar
Icon for Cirrus rankCirrus
Apr 13, 2022

configuring HA with quorum on big-iq fails

Hi guys, new build here, configuring HA between two Big-IQ's, I add my secondary and choose automatic failover, I then add a collector as a quorum. When I click next, the secondary big-iq gets added without issue, then it goes on to setup the quorum which eventually fails with - 

Adding peer failed - Error: ha-quorum: Username and/or password is incorrect

Well it asks for the root password, i have confirmed I can ssh to the device as root and that password without issue, infact if I check the audit logs on the log collector I can see root logs in, makes config changes, saves config then logs out. (the status button the web gui even changes to "quorum")

Although it seems like everything worked other than that message - the HA is really not happy, I get a banner on the primary saying "unexpected HA state. Automatic failover not enabled". I have two other DCD's which I tried to use as quorum  instead same error, I have used the same root password on the managers as I have on the log collectors so really don't think its that.


Any ideas?

1 Reply

  • Did you manage to run the auto HA successfully?

    It's important to note that the big-iq CM should not function as the quorum; instead, the DCD should be configured as the quorum.

    If the initial configuration involved using CM as the quorum, it may have led to unexpected results.

    Additionally, have you ensured that the necessary ports for high availability (HA) are permitted between the BIG-IQ units?
    You can refer to this link for details:

    Keep in mind that the HA process involves various checks, and by examining the logs, you can pinpoint the next steps in formulating an action plan.