Technical Forum
Ask questions. Discover Answers.
cancel
Showing results for 
Search instead for 
Did you mean: 

Secure connection failed - pool 443

THE_BLUE
Cirrostratus
Cirrostratus

i have 2 vs of port 443 and 80 , and pool of 443 and 80 too . from server itself, the website works fine with both ports . But from waf if i enable the vs with pool 443 i receive " secure connection faild" and if i replace it with pool 80 it's work fine. 

What is the issue with 443? i have enable the ssl profile from both side . how to troubleshoot this iisue? 

5 REPLIES 5

Hi THE_BLUE,

If server side ssl, server-ssl profile is required. There may be a issue with the cipher configuration.

Can you try sending a curl request to the server from the F5 command line?

curl -kv "https://serverip" -H "Host: example.com"

If the command returns an SSL error, there may be SNI problem.
https://support.f5.com/csp/article/K41600007

with port 443 i have tried with server ssl and without and i get the same result .

i will try now to use the mentiond command .

Did it work? 

Yes, The issue was related to SNI and i hve inject it to server with iRule.

* TLSv1.2 (OUT), TLS header, Certificate Status (22):
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* Unknown SSL protocol error in connection to serverip:443
* Closing connection 0
curl: (35) Unknown SSL protocol error in connection to serverip:443