cancel
Showing results for 
Search instead for 
Did you mean: 

Installation of 14.1.2.6 fails

Hi All,

 

We have two customers which are trying to install 14.1.2.6 on a partition prior to upgrade from 14.1.2.5. But the installation fails right away with the following erros in /var/log/liveinstall.log

 

*** Live install start at 2020/07/06 18:08:23 ***

info: tm_install::BootLoader::BootLoader_mboot_sync_from_old_conf -- Configurations match.

info: Daemon-driven execution indicated by ENV variable.

info: Repository tm_install version/release is 2.12.0.6/4.0

info: System tm_install version/release is 2.12.0.6/4.0

info: Platform id is C117

/dev/sdd: No medium found

sfdisk: cannot open /dev/sdd for reading

info: Basic disk format validation passed.

info: >++++ result:

info: mount: /dev/mapper/vg--db--sda-set.2._usr is already mounted or /mnt/tm_install/30655.GyI1Fy/usr busy

info:        /dev/mapper/vg--db--sda-set.2._usr is already mounted on /usr

info:        /dev/mapper/vg--db--sda-set.2._usr is already mounted on /opt/.sdm/usr

info:        /dev/mapper/vg--db--sda-set.2._usr is already mounted on /opt/.sdm/lib

info:        /dev/mapper/vg--db--sda-set.2._usr is already mounted on /opt/.sdm/lib64

info: >----

error: status 8192 returned by command: mount -oro  /dev/vg-db-sda/set.2._usr /mnt/tm_install/30655.GyI1Fy/usr 2>/dev/null

info: >++++ result:

info: umount: /mnt/tm_install/30655.GyI1Fy/shared: not mounted

info: >----

error: status 8192 returned by command: umount /mnt/tm_install/30655.GyI1Fy/shared

Terminal error: Could not access configuration source; sda, 2

*** Live install end at 2020/07/06 18:08:27: failed (return code 2) ***

 

I could not find anything related in the F5 knowledge base articles.

 

Customer already tried to delete an create a partition again, but this did not solve the issue.

 

Anyone else facing the same issue? Anyone has a solution?

 

Regards,

Martijn

6 REPLIES 6

Hi Martijn,

 

Did they check the ISO against the MD5 hash??

 

Cheers,

 

Kees

symbolic
Nimbostratus
Nimbostratus

Suffering exactly the same problem trying to install 14.1.2.6 on Virtual Edition running 14.1.2.5.

 

Tried deleting and re-creating the volume, same problem. Checked and MD5 hash is fine, in fact i have been able to install a standalone test instance with 14.1.2.6 (from 14.1.2.5) without any issues.

 

Tried re-installing 14.1.2.2 which was on the volume orignally, and with that I now get the error "failed (Could not access license source; sda, 1 )"

 

*** Live install start at 2020/07/07 18:09:08 ***

info: Daemon-driven execution indicated by ENV variable.

info: Repository tm_install version/release is 2.12.0.3/6.0

info: System tm_install version/release is 2.12.0.6/4.0

info: Platform id is Z100

info: Basic disk format validation passed.

error: status 8192 returned by command: mount -oro /dev/vg-db-vda/set.1._usr /mnt/tm_install/30190.WXdfNO/usr 2>/dev/null

info: >++++ result:

info: mount: /dev/mapper/vg--db--vda-set.1._usr is already mounted or /mnt/tm_install/30190.WXdfNO/usr busy

info:       /dev/mapper/vg--db--vda-set.1._usr is already mounted on /usr

info:       /dev/mapper/vg--db--vda-set.1._usr is already mounted on /opt/.sdm/usr

info:       /dev/mapper/vg--db--vda-set.1._usr is already mounted on /opt/.sdm/lib

info:       /dev/mapper/vg--db--vda-set.1._usr is already mounted on /opt/.sdm/lib64

info: >----

error: status 8192 returned by command: umount /mnt/tm_install/30190.WXdfNO/shared

info: >++++ result:

info: umount: /mnt/tm_install/30190.WXdfNO/shared: not mounted

info: >----

Terminal error: Could not access license source; sda, 1

*** Live install end at 2020/07/07 18:09:09: failed (return code 2) ***

 

Got this from Martijn and it solved it in our F5: https://cdn.f5.com/product/bugtracker/ID915605.html

Yup i got the same answer, so now have upgraded both my boxes, its related to the iRuleLX component being licensed and activated, means that each upgrade from now on will have to remember to perform the remount command before installing the update, and for safety only do it on the offline / standy unit (not sure what remounting /usr read only could potentially do to the live unit, and don't feel like "testing" it on our production kit!)

It's fixed in version 15

Belanger__Yves
Altostratus
Altostratus

Thanks a lot! It's working for me now.

 

Yves