Technical Forum
Ask questions. Discover Answers.
cancel
Showing results for 
Search instead for 
Did you mean: 

Cookie Persistence and Internet Explorer Not Working

sthorns
Nimbostratus
Nimbostratus

Hi all,

 

I have a strange issue with our F5 Load Balancer deployment. The issue we are having is with Cookie Persistence types, we are unable to get the F5 or end server to correctly set and save cookies on user’s machines. This is only affecting users who use Internet Explorer, all other web browsers are not affected. I can confirm the F5 load balancer sends a cookie correctly on Google Chrome and we can see this through chrome://settings/cookies or through the sql db file it produces.

 

We have verified that on IE 8 with Privacy set to “Accept All Cookies” and the F5 Load Balancer set to “Always Send Cookies” & Cookie Insert, we can see a Set-Cookie header during a trace but no physical cookie is saved on the end user’s machine. I have tried both session cookies or expiration based cookies and experience the same issue.

 

From what I am aware, we do no Group Policy blocking of cookies.

 

Any ideas or help appreciated as I am now tearing my hair out trying to understand why it does not work.

 

1 REPLY 1

Kai_Wilke
MVP
MVP

Hi sthorns,

 

LTM's Cookie Persistence Profile issues a "Session Cookie". Because of that, IE won't save it physically to your disk and you can't check its presence via IE's Temporary Internet Files.

 

While tracing the HTTP requests (e.g. via Fiddler, HTTPWatch or even IE's build-in F12-Network Profiler) make sure your LTM inserts a Set-Cookie: BIGipServer${YourPoolName}=Value; Some Params header for the LB cookie. And that the client presents the BIGipServer${YourPoolName}=Value cookie on subsequent request.

 

Cheers, Kai

 


iRule can do… 😉