BIGIP SHOW INOPERATIVE

i tried to upgrade my bigip from v 15.x.x to 16.x.x and i face an issue which is showing in cli BIGIP:INOPERATIVE  and in GUI starting web server , and this take more than one day..

also in cli it show:

load_config_files[10064]: "/usr/bin/tmsh -n -g -a load sys config partitions all base " - failed. -- Error: failed to reset strict operations; disconnecting  from mcpd.  Will reconnect on next command.

so how i can go back to v 15 , i have the backup file saved locally. what should i do to stop the reboot and go back to the previous configration ?

Hello @THE_BLUE

Please use below link to downgrade , I hope your 15.x is still in inactive volume

Br

Aswin

yes the old image is there  and installed but i could not rember in which HD , i have run tmsh show sys software but it does not show result.

Hi

i hope you will be able to find the HD in GUI. when install you can select 15.x in available image and select a volume and install. Update or upgrade a standalone BIG-IP system using the Configuration utility | BIG-IP update and upgrade guide

i can not access the GUI it show starting web server and keep loading.

Could you please try to restart httpd service (gui) and try to access GUI

Command via cli - bigstart restart httpd

Use the command to see the installed volume -tmsh show sys software status

Use this link for upgrade via cli- myF5

i have restarted and it show OK , when i run tmsh show sys software status it show nothing , i noticed all comand of tmsh does not show result where other command working fine

Usually it will work after this and command will also run.

I suggest to raise F5 support request and work with them , without more logs and seeing status it’s very hard to suggest you more steps . Do you have F5 support access?

NO , i tried to raise case from portal but it show negix product only

You create a support case on <a href://my.f5.com>MyF5</a> (my.f5.com). To provide you with the best possible service, F5 requests that you provide the following:

Serial number or registration key for your product

Specific information about your issue, depending on your product

Priority-level for your case

If your device have support, then you will able to raise a case. Select bigip

Hi @THE_BLUE ,

Let me help you out with creating a case from the portal. I’ll private message you on the side for your email address you use to log a case and the serial number. The reason you’re seeing only NGINX is the serial number of the F5 device isn’t associated to your email address. Look out for my PM.

Cheers,

Mo.

thank you all.. it’s solved:

systemctl stop overdog.

bigstart restart.

systemctl start overdog.

Hey @THE_BLUE , glad it’s solved. I’ll mark your post as the solution.

Cheers,

Mo

Had exact the same error, this did not resolve it.

This solved it: Observed Error ‘‘failed to reset strict operations; disconnecting from mcpd’’ and mcpd goes restart loop.

rm -rf /var/apm/lib/rpm
epsec -f refresh
tmsh load sys config