Hi, anyone else run into this error while continuing to up the XML memory allocation? We’ve gone to 500mb to 700mb (SOL10803) and still having this error re-occur. I have a case open with F5, but curious if anyone has run into this and what your (hopefully) final solution was.
Full error “ASM out of memory error: event code X239 Exceeded maximum memory assigned for XML/JSON processing”
We are at 900MB XML memory now and so far all is good. I understand from F5 support we can increase to a maximum of 2000MB. There is an enhancement request (ID380171) to provide tools to monitor memory used by XML parser - for now there is no visibility into XML memory use.
Wow, 3GB. I suspect the ceiling we’re given is due to our hardware. We are running on 3900 with 8GB RAM and have ASM/LTM, both provisioned as nominal. I understand we can gain more memory by re-provisioning LTM as minimal, as our current LTM usage is very light. If we run into this issue again we plan to jump to F5 recommended 2000MB.
I heard back from F5 support, they are suspecting a memory leak and have issued me an engineering HF. They identify the issue ID489705, memory leak in bd’s XML engine. We’re running good at 900MB XML memory, so staying put for now. I’m hoping this fix is included in the Ghost HF.
Stupid question, but I am assuming that if you run into this problem, there may be tcp streams that do not get processed by ASM and are just sent thru without being inspected?
When this issue occurs traffic is blocked for that virtual server, I believe error is something like not enough memory to process XML request. It fails close.
Does anyone have a “final” solution for this. I have the exact same case, we up from 500 to 700 but still having issues with the out of memory logs still appearing.
The trial and error of updating the Total XML Memory according to the “excedeed memory allocated” is not a good option, because it seems the more memory you configure the more memory XML resources will consume.
At least the logs of exceeded memory allocated in bd.log should give us the correct value and not only 20, 30 or 40 Mb more than we have configured, and even if you configure more 200MB it still is giving the same messages.
I have followed theses 2 KB below and by modify the values of total_xml_memory (max 1GB) and additional_xml_memory_in_mb . I have no longer an ASM out of memory XML error.