Forum Discussion

Raphaël_Guisol1's avatar
Icon for Nimbostratus rankNimbostratus
Dec 07, 2010

SharePoint 2010 : access denied on javascript




I tested SharePoint 2010 with success. Now i configured it to work with the Big-Ip F5 with the same F5 configuration i have for SharePoint 2007.



Then, when i try to show the contextual menu of a document in a document list, i have javascript error with "access denied", for instance on "core.js" and "inplview.js" files.



I noticed that this problem is only valid for SSL.



Any idea ?




9 Replies

  • Hi Raphael,



    Have you checked the Sharepoint 2007 deployment guides here:





    Microsoft Office SharePoint 2007 (BIG-IP v10 System)


    Microsoft Office SharePoint 2007 (BIG-IP v9.x, LTM, WebAccelerator, FirePass)


    Microsoft Office SharePoint Server 2007 (HP Guide for BIG-IP LTM/WebAccelerator)



  • We are getting the exact same issue but on SharePoint 2010. As soon as we put the SharePoint servers behind the F5 using SSL we started getting the Access is denied core.js and inplview.js message when we use the drop down menu on items in the main page we get this error. Yes we have checked the deployment guides.
  • Helen_Johnson_1's avatar
    Historic F5 Account
    Hi folks,



    This is a very interesting problem you're both experiencing.



    Are either of you using any sort of acceleration profiles in your configurations? And, are you using only the Local Traffic Manager product, or are you using Web Accelerator, or Access Policy Manager as well?



  • Per this post that Raphaël replied to, it looks like there is a hard coded reference to http: in the Javascript:




    You could confirm this by testing through LTM, capturing the headers using Fiddler and comparing that with a trace direct to a pool member via SSL to see if there is anything different with the requests from the client to LTM?



    You could try to rewrite the http: reference to https: using a stream profile and STREAM::expression based iRule:




    But it seems like this should be handled by Alternate Access Mapping. And if it's not, it seems like a bug in the MOSS mapping functionality.



  • Hello,



    On my side, my problem was resolved by configuring the default AAM in SharePoint with https instead http. With the SSL offload, a default AAM with http on my SharePoint 2007 farm worked, but not anymore on SharePoint 2010.



    Hope that help...



    Kind regards,
  • I finally got this resolved after opening a support call with Microsoft. Our settings on the F5 were fine, and no iRule was needed. We ended up going in SharePoint 2010 and removing all AAM's (alternate access mappings) including the internet zone. Then we just created 2 internal mappings and that fixed our problem. I hope this helps further users as i'm sure other's will run into this.




    Please change your AAMs to this and test


    Internal URL Zone Public URL for Zone




    -- Remove the internet zone


  • Hi Joe,



    As you use also SharePoint with F5 SSL Offloading, how do you deal with the Search Service ? Did you setup the crawler content source with an address configured on the F5, or do you setup it to go directly to an internal address (without passing by the F5) and using "server name mappings" ?



    I have the second option because the first one won't work for me. I tried the first one many times to resolve a document previews problem which won’t open in FAST Search Result, without success...



    Thank you,
  • I experienced similar problems and despite having AAM setup correctly as per the above posts and the solutions guide, the problem was related to the use of non-standard ports for HTTP and HTTPS. I didn't get to the bottom of the problem but was able to switch to 80 and 443 anyway. A word of warning to those grappling with AAM's try reverting to the standard ports if possible.