Forum Discussion

Sean_McMahon_82's avatar
Sean_McMahon_82
Icon for Nimbostratus rankNimbostratus
Nov 03, 2010

LTM 10.2 VE on VMware Workstation 7

Hi team, Has anyone tried to get 10.2 VE running on a VMware workstation 7 machine.

 

 

Im having issues with the network adaptors been initialized.

 

 

 

Inside the interface they seem to be missing MAC addresses. Also can not pass any traffic to or from the SELF IP.

 

 

 

With version 10.1 it seem to resolve the issue once an adaptor was added to a VLAN. this does not resolve the issue in 10.2

 

 

 

Inside my vmx file i have set those two interfaces to e1000.

 

 

 

Anyone have any luck getting 10.2 to work or if anyone can point me in the right direction that would be great.

 

 

 

 

 

 

 

 

 

 

8 Replies

  • 10.2 VE is only supported on VMware ESX and ESXi and with a non-trial license key. 10.2 VE is not supported on VMware Workstation 7.

     

     

     

  • Do you have a valid license for 10.2? I don't think the interfaces will be initialized until the license and config load.

     

     

    Can you try vmxnet3 for the second and third interfaces?

     

     

    ethernet1.virtualDev = "vmxnet3"

     

    ethernet2.virtualDev = "vmxnet3"

     

     

    Aaron
  • Sometimes Workstation won't startup VMXNET3 without pciE root bridges being present.

    In addition to changing the virtualDev type to vmxnet3, you'll need to add this to the .vmx:

    pciBridge4.present = "TRUE"
    pciBridge4.virtualDev = "pcieRootPort"
    pciBridge4.functions = "8"
    pciBridge5.present = "TRUE"
    pciBridge5.virtualDev = "pcieRootPort"
    pciBridge5.functions = "8"
    pciBridge6.present = "TRUE"
    pciBridge6.virtualDev = "pcieRootPort"
    pciBridge6.functions = "8"
    pciBridge7.present = "TRUE"
    pciBridge7.virtualDev = "pcieRootPort"
    pciBridge7.functions = "8"

    technically, one can add just one pcieRootPort, but I've not tried that with the full 9 VMXNET3 configuration so I've shown you what ESX and ESXi deploy in their .vmx files.

  • Hey team thanks for the replies.

     

     

    Hoolio changing the NIC type fixed it.

     

     

    Yes i had a valid license.

     

     

  • I'm having a similar issue with ESX 4.0, the problem is I don't have view or access to see the ESX/vsphere view because this is being hosted by another provider. I was able to get my VE running on ESX 4.0 here in house using the trial license. We've now moved it off-ste, received a production license but my interfaces are stuck at initializing with no MAC address. Any ideas? It's frustrating when you have to rely on the provider for the ESX side of the house.
  • Hi Nando,

     

     

    I'm not certain, but I think you need to add the interfaces to a VLAN before they'll change from uninitialized to up. Or maybe someone else has ideas on this. Else, you could open a case with F5 Support if you have a full license.

     

     

    Aaron
  • Nevermind... the provider just changed it to VMNXNET3 apparently it was set for VMNXNET2. UGH!! Thanks for looking!
  • Robin_Mordasie1's avatar
    Robin_Mordasie1
    Historic F5 Account

    I cross posted this on "What Hypervisors have you tried LTM VE in?"

     

    Success:

     

    Vmware Fusion 3.1.2

     

    OSX 10.6.5

     

    BIGIP-VE 10.2 build 1707

     

     

    Be sure to edit the .vmx file as follows:

     

    ethernet1.virtualDev = "vmxnet3"

     

    ethernet2.virtualDev = "vmxnet3"

     

     

    The interfaces leave the UNINITIALIZED state after putting them in a vlan, and I have tested that they do indeed pass traffic