Forum Discussion

RAHUL0018's avatar
Icon for Altocumulus rankAltocumulus
Jan 08, 2021

Issue in Downloading Files (pdf/xls/jpeg) with ASM Policy and http profile enabled

Hello Everyone,


I have an environment in which I have enabled ASM Policy and is in blocking mode. The HTTP Profile is also enabled.

I am getting 'Failed-Network Error' while downloading files and LTM logs shows me this error


Jan 8 10:53:38 err tmm3[20410]: 011f0016:3: http_process_state_prepend - Invalid action:0x10a010 Server sends too much data. serverside clientside (Server side: vip=/Common/profile=http pool=/Common/)


I have tried so many solutions given on different forums, but could not get through this. Some suggest to disable http and ASM for particular URI, upon doing which, the webpage stops loading.


Kindly help.


3 Replies

  • The virtual server is configured with an HTTP profile, and the BIG-IP system receives a response from the pool member that either contains more data than indicated in the Content-Length header or has additional data following the ending chunk of a chunked response.


    Article K42151600 may help you to solve issue.


    My issue has solved with this article hope yours will be solved..

    • RAHUL0018's avatar
      Icon for Altocumulus rankAltocumulus

       . I have applied the iRule, but still, it dint work. Please confirm if applying iRule in your case resolved the issue.



      • Samir's avatar
        Icon for MVP rankMVP

        My environments irule worked perfectly. Did you enable some db variable​ and try...

        Note- Try to configure setting in non business hour. Follow the process w.r.t company policy.