Forum Discussion

david_il_326231's avatar
Icon for Nimbostratus rankNimbostratus
Jul 05, 2017

Cannot detect BitDefender anti-virus

Trying to connect to the VPN using Big-ip, but it fails saying it cannot detect anti-virus, yet I have bitdefender on my pc. Is there a work around for this?


2 Replies

  • If you not the APM (F5 device) administrator, talk with who manages the APM device. APM can control which antivirus it accepts or not.


    If you are the APM administrator, you need to review your APM policy and check if this antivirus is allowed.


    • Shadow_Ninja's avatar
      Icon for Nimbostratus rankNimbostratus

      i'm not an expert with APM, however, I did set it up for a customer. Not a large consumer, all mac and windows BYOD. Although, I've seen all the big AV vendors and others in the logs FWIW. The only time I've seen this behavior was actually 3 times over the span of 2 years specifically pertaining to BitDefender. I've tried to work with F5 support, but I get busy and abandon cases. I also contacted BitDefender support to no avail. Bit Defender wanted me to disable each component at a time, which did not work and I gave up.


      BitDefender worked solid for a year then broke. worked for 6 months and then broke again, all the while every other AV vendor works successfully. Only a few users are bitdefender in the environment, but I installed bitdefender on a BYOD and repro issue every time. uninstall bit defender, windows defender takes effect and passes the host check and moves on.


      I've also seen this with AntiVirus deployed thru JAMF, Ivanti, and another where it does not pick up the AV engine in sessionID reports, or it shows deployment tool name instead of AV and will have session.results issues in the log


      I have a suspicion that it's the AV vendors behind on OPSWAT database. I cannot prove that even if it was the issue. I would bet tho its not F5, but rather the smaller AV shops out there lagged time with OPSWAT updates. I do run the epsec pkg update monthly, however, for these scenarios it did not fix the problem and had to wait it out..


      I provided multiple qkviews but left case hanging..and never got RCA