IllegalArgumentException using iControl assembly 11.2

The method, LocalLB.Monitor.get_template_list(), returns a IllegalArgumentException from the 11.x BigIP, I use iControl assembly 11.2:

Error log:

AxisFault

faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException

faultSubcode:

faultString: org.xml.sax.SAXException

java.lang.IllegalArgumentException

faultActor:

faultNode:

faultDetail:

{WebServices - Axis}stackTrace:org.xml.sax.SAXException

java.lang.IllegalArgumentException at org.apache.axis.encoding.ser.SimpleDeserializer.onEndElement(SimpleDeserializer.java:176) at org.apache.axis.encoding.DeserializerImpl.endElement(DeserializerImpl.java:502) at org.apache.axis.encoding.DeserializationContext.endElement(DeserializationContext.java:1087) at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:171) at org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141) at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:345) at org.apache.axis.message.RPCElement.getParams(RPCElement.java:384) at org.apache.axis.client.Call.invoke(Call.java:2467) at org.apache.axis.client.Call.invoke(Call.java:2366)at org.apache.axis.client.Call.invoke(Call.java:1812)at iControl.LocalLBMonitorBindingStub.get_template_list(LocalLBMonitorBindingStub.java:1085)

Axis log:

2012-07-16T18:32:51.015Z DEBUG [xxx@xxx][Serving-127.0.0.1:40136] org.apache.axis.ConfigurationException - Exception: org.apache.axis.ConfigurationException: No service named urn:iControl:LocalLB/Monitor is available

at org.apache.axis.configuration.FileProvider.getService(FileProvider.java:233) [axis-1.jar:na]

at org.apache.axis.AxisEngine.getService(AxisEngine.java:311) [axis-1.jar:na]

at org.apache.axis.MessageContext.setTargetService(MessageContext.java:756) [axis-1.jar:na]

at org.apache.axis.transport.http.HTTPTransport.setupMessageContextImpl(HTTPTransport.java:89) [axis-1.jar:na]

at org.apache.axis.client.Transport.setupMessageContext(Transport.java:46) [axis-1.jar:na]

at org.apache.axis.client.Call.invoke(Call.java:2738) [axis-1.jar:na]

at org.apache.axis.client.Call.invoke(Call.java:2443) [axis-1.jar:na]

at org.apache.axis.client.Call.invoke(Call.java:2366) [axis-1.jar:na]

at org.apache.axis.client.Call.invoke(Call.java:1812) [axis-1.jar:na]

Any ideas?

That’s an odd error. What version of LTM are you attempting to connect to? Can you open the WSDL with a browser:

https://bigip/iControl/iControlPortal.cgi?WSDL=LocalLB.Monitor

Also, could you post your initialization code for your iControl.Interfaces object? The error message stating “Serving-127.0.0.1:40136” doesn’t look like you are connecting to an LTM, but rather to localhost.

-Joe

Hi Joe,

I work with Ariel and will be also following this issue. Here is the WSDL you asked: <?xml version="1.0" ?><!--Copyright (c) 1996-2012, F5 Networks, Inc., Seattl - Pastebin.com

The initialization code is this (we don’t do much):

Interfaces interfaces = new iCon trol.Interfaces();

interfaces.initialize(, , );

interfaces.getLocalLBMonitor().get_template_list(); // this fails

Regarding the 127.0.0.1 address, that appears because Ariel took the information from one of our logs, and our application was serving an internal client. We connect to a real LTM. Indeed, there are only two methods that fail (the other is LocalLBPool.get_all_member_statistics()), the rest work normally.

Regards.