Technical Forum
Ask questions. Discover Answers.
Showing results for 
Search instead for 
Did you mean: 
Custom Alert Banner

Custom bash script at startup doesn't work (BIG-IP VM 17.1.1)


I need to run a custom script at the startup of my BIG-IP VM (version: 17.1.1 Build 0.0.6 Final). In order to reach my goal, I followed this articole by F5 but unfortunately it didn't work:

the file didn't exist so I creted it by my self in /config/, edited, saved and made it executable. if I run it via CLI it works, but the system doesn't run it at the startup (I tried to reboot many times). where am I going wrong?


F5 Employee
F5 Employee

The way that article is organized may lead to some confusion, because there are two initial procedures at the top that gives instruction to create a script and set it executable, but in two slightly different ways depending on version. Then below the "old version" procedure there is another one for "Enable the BIG-IP or BIG-IQ system to run the script". If you missed the last part, it would lead to the behavior you described.