cancel
Showing results for 
Search instead for 
Did you mean: 

b snat translation <ip> udp timeout immediate

Jim_24689
Nimbostratus
Nimbostratus

Hello -

 

We are working with a call center VOIP vendor and are experiencing some integration issues. The primary problem is that the vendor cannot work with ephemeral ports. If the F5's connection table is population with a connection say:

 

src -ip:port des-ip:port

 

If another connection occurs from the same scr ip to the same dest ip and port,, the LTM will use an ephemeral src port. Standard behavior. But the vendor's product will not respond to the ephemeral port but to the standard SIP port 5060.

 

The VOIP vendor recommeded changing the udp timeout of a snat translation to "immediate" . The man pages on the LTM indicates that this a valid command. However , when executed , the following occurs:

 

 

b snat translation udp timeout immediate

 

BIGpipe SNAT translation address creation error:

 

01070149:3: Translation address cannot have a zero udp idle timeout.

 

Here is a snip from the man page

 

bigpipe snat translation {}

 

bigpipe snat translation ( │ all) \

 

[{] [}]

 

::=

 

 

::=

 

addr ( │ none)

 

arp (enable │ disable)

 

(enable │ disable)

 

ip timeout ( │ immediate │ indefinite)

 

limit

 

tcp timeout ( │ immediate │ indefinite)

 

udp timeout ( │ immediate │ indefinite)

 

unit

 

 

We are running on 1600s Version 10.2.4

 

 

Any suggestions , work arounds would be greatly appreciated.

 

Thanks -jim

 

3 REPLIES 3

nitass
F5 Employee
F5 Employee
i cannot set snat translation immediate idle timeout as welll even online help and sol7606 both mention it is an option. i tested on 10.2.4 and 11.2.1.

 

 

sol7606: Overview of BIG-IP idle session timeouts

 

http://support.f5.com/kb/en-us/solutions/public/7000/600/sol7606.html

 

 

anyway, are you using snat to handle traffic (not virtual server)? if you are using virutal server, can you try to set immediate idle timeout on profile? i understand the shorter (between profile and snat) will take effect.

What_Lies_Bene1
Cirrostratus
Cirrostratus
Does the connecting 'client' use the correct port. If so you could try setting the Source Port Preservation to Preserve Strict on the VS?

Jim_24689
Nimbostratus
Nimbostratus

Thank you all for the suggestions. I will give them a shot. -jim