Forum Discussion

Mahesh_56912's avatar
Icon for Nimbostratus rankNimbostratus
Oct 12, 2010

ssh timeout after 5 minutes

We have recently migrated few applications from old F5 boxes to the new F5 boxes.



Before migrating, the ssh login was working well (i.e. we were not getting any session timeout while logging using putty client). After migration, If we keep the ssh session idle (using putty & user login) for more than 5 mins it automatically get disconnected.



We need to understand if there is any setting available behind F5, to get this issue resolve.



To highlight here is that HTTP applications are working normally as before.








4 Replies

  • To confirm - is this SSH to the F5 or to a VIP?



    You might be running into a tcp-idle-timeout setting in your tcp profile. Were you using a custom profile for SSH traffic in your previous config?
  • George_Watkins_'s avatar
    Historic F5 Account
    Add these lines to ~/.ssh/config:

    Host *
        ServerAliveInterval 10

    That will send a message through the tunnel to server side and keep the connection open.

  • MB: I think Chris is on the money.



    If you choose to use George's solution (which will work also, but means you need to change all of your clients), still keep in mind that each VIP has a TCP profile bound to it and TCP behaviors are tunable per vip. By default we use a 5 minute (300 seconds) idle timeout value. To fix this, simply create a new TCP profile for this virtual server and change the idle timeout to something that makes sense for your environment.



    This is a common issue for FTP as well - the control channel will time out during large transfers. But I digress.



  • Here's a thorough solution which describes the various idle timeouts:



    SOL7606: Overview of BIG-IP idle session timeouts